無料ブログ「rentafree.net」の管理人ブログ

ブラウザ対応表

ブログ管理ページのブラウザ対応表です。

公開ブログの対応ブラウザはテンプレート次第です。
(公式テンプレートなら、少なくともこのページに記載されているブラウザでの閲覧は全て可能です。)


PCブラウザ
ブラウザ名 (コア名)
バージョン
ステータス
説明
Firefox (Gecko)
11.0以上推薦
すべての機能が利用可能で推薦ブラウザです。
11.0未満対応
タグ直接編集機能が利用できません。
8.0未満対応
コンテキストメニューが独自UIとなります。
4.0未満対応画像挿入機能からの画像アップロードができません。
3.0未満
非対応
ブログエディターが利用できません。
IE (Trident)
10.0以上
対応コンテキストメニューが独自UIとなります。
10.0未満
対応
コンテキストメニューが独自UIとなります。
画像挿入機能からの画像アップロードができません。
9.0未満
非対応
ブログエディターが利用できません。
Chrome (Blink)
28.0以上
対応コンテキストメニューが独自UIとなります。
バージョン28からBlinkとなります。(27まではWebKit)
4.0以上対応コンテキストメニューが独自UIとなります。
4.0未満
非対応ブログエディターが利用できません。
Safari (WebKit)3.1以上
対応コンテキストメニューが独自UIとなります。
3.1未満
非対応ブログエディターが利用できません。
Opera (Presto)15以上不明バージョン15から独自開発のPrestoではなくWebKitとなります。
他のWebkitブラウザと同じ対応状況になると思われます。
12以上対応コンテキストメニューが独自UIとなります。
12未満対応コンテキストメニューが独自UIとなります。
画像挿入機能からの画像アップロードができません。
9未満非対応ブログエディターが利用できません。
Pale Moon(Goanna)26以上
対応GoannaレンダリングエンジンがGeckoベースなので全ての機能に対応していると思われますが、マイナーブラウザなので推薦はしません。
26未満
不明
バージョン26未満はFirefoxベースです。

タッチパネル (モバイル)
ブラウザ名 (コア名)バージョン ステータス説明
Chrome (Webkit)
全バージョン
入力可能基本的にコンテキストメニューの拡張項目が出ません。
Opera (Presto)
14以上
不明バージョン14から独自開発のPrestoではなくWebkitとなります。
他のWebkitブラウザと同じ対応状況になると思われます。
12.10以上入力可能基本的にコンテキストメニューの拡張項目が出ません。
12.10未満
非対応ブログエディターが利用できません。
Firefox (Gecko)全バージョン
入力可能
基本的にコンテキストメニューの拡張項目が出ません。
Pale Moon(Goanna)全バージョン
入力可能基本的にコンテキストメニューの拡張項目が出ません。
Safari (Webkit)
不明未確認
Apple系端末でのテストは行なっていません。
テキスト選択とコンテキストメニューの両立できるブラウザが存在しないため、
タッチパネル操作時はコンテキストメニューの拡張機能が無効化され機能が制限されます。


ブログの記事投稿ページでブラウザによる違いが生じます。
その他のページの機能はブラウザによる違いはほぼ発生しません。

エディタ上で右クリックした場合、独自のコンテキストメニュー(右クリックメニュー)を表示します。
ブラウザによってはコンテキストメニューの操作を阻止する設定ができますが、コンテキストメニューが表示されないと一部編集機能が利用できません。

ブログエディタ非対応ブラウザでも、ソースモード(HTML直接入力)で編集して投稿することは可能です。

画像アップロード機能非対応のブラウザでも、ファイルマネージャからのファイルアップロードは可能です。

IPアドレスが変わるとログインセッションが無効になります。
携帯電話に搭載されているブラウザはアクセス毎にIPアドレスが変わる可能性が高いので、通常の認証方法では要ログインページへのアクセスができない可能性が高いです。
その場合はSSLログインページにある「ワンタイム認証」機能を利用してください。

記載されていないブラウザのほとんどは、独自のレンダリングエンジンを持たず、上記ブラウザのいずれかのコアを利用しています。
その場合は、利用しているコアのブラウザと同じ挙動をします。

対応ブラウザで不具合がありましたら報告していただければ助かります。